aboutsummaryrefslogtreecommitdiffstats
path: root/games/aisleriot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/aisleriot/Makefile')
-rw-r--r--games/aisleriot/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/games/aisleriot/Makefile b/games/aisleriot/Makefile
index 75fe49599f14..e450d8e516e6 100644
--- a/games/aisleriot/Makefile
+++ b/games/aisleriot/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= aisleriot
-PORTVERSION= 3.18.2
+PORTVERSION= 3.22.2
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -14,13 +14,16 @@ BUILD_DEPENDS= itstool:textproc/itstool \
appstream-builder:devel/appstream-glib \
bash:shells/bash
LIB_DEPENDS= libguile-2.0.so:lang/guile2 \
- libcanberra-gtk3.so:audio/libcanberra-gtk3
+ libcanberra-gtk3.so:audio/libcanberra-gtk3 \
+ libgc-threaded.so:devel/boehm-gc-threaded
-CONFLICTS= sol-*
+CONFLICTS= sol-[0-9]*
PORTSCOUT= limitw:1,even
USES= desktop-file-utils gettext gmake gnome pathfix pkgconfig tar:xz
-USE_GNOME= gconf2 gtk30 intlhack librsvg2 libxml2:build
+USE_GNOME= cairo gconf2 gtk30 intlhack librsvg2 libxml2:build
+USE_XORG= x11
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-card-theme-formats=svg \
--with-guile=2.0
@@ -30,4 +33,5 @@ CONFIGURE_SHELL=${LOCALBASE}/bin/bash
GCONF_SCHEMAS= aisleriot.schemas
GLIB_SCHEMAS= org.gnome.Patience.WindowState.gschema.xml
+INSTALLS_ICONS= yes
.include <bsd.port.mk>