aboutsummaryrefslogtreecommitdiffstats
path: root/games/alephone/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/alephone/Makefile')
-rw-r--r--games/alephone/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index d25e4b4b24e5..7d0182652ece 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -18,18 +18,18 @@ COMMENT= The open source version of Bungie's Marathon game
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12:install \
SDL_image.10:${PORTSDIR}/graphics/sdl_image:install
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${PERL} -pi -e 's,^#include \"network_modem.h\".*,,' \
${WRKSRC}/Source_Files/Network/network.cpp \