aboutsummaryrefslogtreecommitdiffstats
path: root/games/angband/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/angband/Makefile')
-rw-r--r--games/angband/Makefile36
1 files changed, 16 insertions, 20 deletions
diff --git a/games/angband/Makefile b/games/angband/Makefile
index 7adef69cc6cc..2deed5ed7392 100644
--- a/games/angband/Makefile
+++ b/games/angband/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: angband
-# Date created: 21 Feb 1997
-# Whom: Matthew Hunt <mph@pobox.com>
-#
+# Created by: Matthew Hunt <mph@pobox.com>
# $FreeBSD$
-#
PORTNAME= angband
-PORTVERSION= 3.3.2
+PORTVERSION= 3.4.1
CATEGORIES= games
-MASTER_SITES= http://rephial.org/downloads/3.3/
+MASTER_SITES= http://rephial.org/downloads/${PORTVERSION:R}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= pav@FreeBSD.org
@@ -17,21 +13,21 @@ COMMENT= Rogue-like game with color, X11 support
USE_GMAKE= yes
ALL_TARGET= #
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-setgid=games --disable-sdl --disable-sdl-mixer --with-varpath=/var/games/angband
-.if !defined(WITHOUT_X11)
-USE_XORG= sm x11
-CONFIGURE_ARGS+= --with-x
-.else
-CONFIGURE_ARGS+= --with-x=no
-.endif
-CONFIGURE_ENV= ac_cv_path_mkdir=mkdir
-CPP= cc -E
+CONFIGURE_ARGS= --with-setgid=games --localstatedir=/var
+LDFLAGS+= -lncursesw
+
+OPTIONS_DEFINE= X11
+X11_DESC= Enable X11 (graphical) backend
-pre-fetch:
-.if !defined(WITHOUT_X11)
- @${ECHO_MSG} "You could define WITHOUT_X11, if you don't want X support"
+OPTIONS_DEFAULT=X11
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
+USE_XORG= sm x11
+RUN_DEPENDS= xorg-fonts-miscbitmaps>=0:${PORTSDIR}/x11-fonts/xorg-fonts-miscbitmaps
.else
- @${ECHO_MSG} "Building without X support"
+CONFIGURE_ARGS+=--disable-x11
.endif
post-patch: