aboutsummaryrefslogtreecommitdiffstats
path: root/games/armagetron/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/armagetron/Makefile')
-rw-r--r--games/armagetron/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
index 4ce7e0870c4d..9547f5e1b47d 100644
--- a/games/armagetron/Makefile
+++ b/games/armagetron/Makefile
@@ -8,7 +8,7 @@
PORTNAME= armagetron
PORTVERSION= 0.2.8.2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}ad/${PORTNAME}ad-src/${PORTVERSION}
DISTNAME= armagetronad-${PORTVERSION}
@@ -17,29 +17,39 @@ EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ianthetechie@gmail.com
COMMENT= A multiplayer networked Tron clone in 3D
-USE_GL= gl
-USE_SDL= sdl image
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CFLAGS} -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`"
-CONFIGURE_ARGS= --disable-etc
+CONFIGURE_ARGS= --disable-etc --disable-initscripts
+CXXFLAGS+= ${CFLAGS} -I${LOCALBASE}/include
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
xml2.5:${PORTSDIR}/textproc/libxml2
-OPTIONS= MUSIC "Compile in support for background music" on
+OPTIONS= MUSIC "Compile in support for background music" on \
+ ARMA_SERVER_ONLY "Build dedicated server only" off
.include <bsd.port.pre.mk>
+.if defined(WITH_ARMA_SERVER_ONLY)
+CONFIGURE_ARGS+= --disable-glout
+PLIST_SUB+= CLIENT="@comment " SERVER="" SUFFIX="-dedicated"
+PKGNAMESUFFX= -dedicated
+USE_RC_SUBR= armagetronad_dedicated
+.else
+USE_GL= gl
+USE_SDL= sdl image
+CXXFLAGS+= `${SDL_CONFIG} --cflags`
+PLIST_SUB+= CLIENT="" SERVER="@comment " SUFFIX=""
.if !defined(WITHOUT_MUSIC)
USE_SDL+= mixer
CONFIGURE_ARGS+=--enable-music
.endif
+.endif
# This script isn't needed and only causes install problems
-CONFIGURE_ARGS+=--disable-uninstall
+CONFIGURE_ARGS+=--disable-uninstall
post-patch:
@${REINPLACE_CMD} -e 's|sdl11-config|${SDL_CONFIG}|g' ${WRKSRC}/configure