aboutsummaryrefslogtreecommitdiffstats
path: root/games/bomns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/bomns/Makefile')
-rw-r--r--games/bomns/Makefile65
1 files changed, 24 insertions, 41 deletions
diff --git a/games/bomns/Makefile b/games/bomns/Makefile
index 22f8ca31b9cf..317dbca53987 100644
--- a/games/bomns/Makefile
+++ b/games/bomns/Makefile
@@ -2,57 +2,40 @@
# $FreeBSD$
PORTNAME= bomns
-PORTVERSION= 0.99.2
-PORTREVISION= 2
+PORTVERSION= 0.99.3
CATEGORIES= games
-MASTER_SITES= SF/greenridge/Bomns%20for%20Linux/Bomns%20for%20Linux%20${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= games@FreeBSD.org
COMMENT= Best old-school Deathmatch game ever (only for two players)
-USES= pkgconfig
-USE_BZIP2= yes
-USE_SDL= mixer sdl
-WANT_GNOME= yes
-INSTALLS_ICONS= yes
-
-GNU_CONFIGURE= yes
-CPPFLAGS+= `${SDL_CONFIG} --cflags`
-LDFLAGS+= `${SDL_CONFIG} --libs`
-CONFIGURE_ARGS= --program-transform-name=
+LICENSE= GPLv2
-OPTIONS_DEFINE= EDITOR LAUNCHER OPTIMIZED_CFLAGS
-OPTIONS_DEFAULT= EDITOR LAUNCHER OPTIMIZED_CFLAGS
-EDITOR_DESC= Enable building of the map editor
-LAUNCHER_DESC= Enable building of the GTK2 launcher
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-OPTIONS_SUB= yes
+USE_GITHUB= yes
+GH_ACCOUNT= keithfancher
+GH_PROJECT= Bomns-for-Linux
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 113be27
-EDITOR_CONFIGURE_ENABLE= editor
-
-LAUNCHER_USE= GNOME=gtk20
-LAUNCHER_CONFIGURE_ENABLE= launcher2
+USES= cmake
+USE_SDL= mixer sdl
+USE_GNOME= gtk20
+CMAKE_ARGS+= -Wno-dev
+USE_CSTD= gnu89
+INSTALLS_ICONS= yes
-.include <bsd.port.options.mk>
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LIBS=-L${LOCALBASE}/lib
-post-patch:
-# Fix SDL include statement.
-.for f in *.cpp *.h
- @${FIND} ${WRKSRC}/src -type f -name ${f} -print0 | \
- ${XARGS} -0 \
- ${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
-.endfor
+PORTDOCS= AUTHORS ChangeLog README
+OPTIONS_DEFINE= DOCS
-# Remove -lSDL linker flag.
-.for f in Makefile.am Makefile.in
- @${FIND} ${WRKSRC}/src -type f -name ${f} -print0 | \
- ${XARGS} -0 \
- ${REINPLACE_CMD} -e 's|-lSDL || ; s|-lSDL$$|| ; s|-lpthread||'
-.endfor
+post-install:
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-# Enable/disable compilation optimizations.
-.if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS)
- @${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>