aboutsummaryrefslogtreecommitdiffstats
path: root/games/chromium-bsu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/chromium-bsu/Makefile')
-rw-r--r--games/chromium-bsu/Makefile34
1 files changed, 15 insertions, 19 deletions
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index fb1548a0b2c4..04d9e698d125 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -2,49 +2,45 @@
# $FreeBSD$
PORTNAME= chromium-bsu
-PORTVERSION= 0.9.15.1
-PORTREVISION= 4
+PORTVERSION= 0.9.16.1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Chromium%20B.S.U.%20source%20code/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Arcade-style, top-scrolling space shooter
-LIB_DEPENDS= libglpng.so:graphics/glpng \
- libftgl.so:graphics/ftgl \
- libfontconfig.so:x11-fonts/fontconfig
+LIB_DEPENDS= libGLC.so:graphics/quesoglc
GNU_CONFIGURE= yes
-USES= localbase pkgconfig
+USES= gmake localbase pkgconfig
+USE_SDL= sdl2 image2
USE_GL= gl glu
-CONFIGURE_ARGS= --disable-glc
+CONFIGURE_ARGS= --disable-sdl \
+ --disable-sdlmixer \
+ --disable-sdlimage \
+ --disable-ftgl \
+ --disable-glut \
+ --disable-glpng
+
INSTALLS_ICONS= yes
PORTDOCS= *
PORTDATA= *
OPTIONS_DEFINE= NLS DOCS
-OPTIONS_SINGLE= AUDIO VIDEO
+OPTIONS_SINGLE= AUDIO
OPTIONS_SINGLE_AUDIO= OPENAL SDL_MIXER
-OPTIONS_SINGLE_VIDEO= SDL GLUT
-OPTIONS_DEFAULT= OPENAL SDL
+OPTIONS_DEFAULT= OPENAL
OPTIONS_SUB= yes
-VIDEO_DESC= Video output selection
AUDIO_DESC= Audio output selection
OPENAL_DESC= Use OpenAL for audio
SDL_MIXER_DESC= Use SDL_mixer for audio
-SDL_DESC= Use SDL for video output
-GLUT_DESC= Use GLUT for video output
-SDL_MIXER_USE= SDL=mixer
-SDL_MIXER_CONFIGURE_ENABLE=sdlmixer
+SDL_MIXER_USE= SDL=mixer2
+SDL_MIXER_CONFIGURE_ENABLE=sdl2mixer
OPENAL_USES= openal:al,alut
OPENAL_CONFIGURE_ENABLE=openal
-GLUT_USE= GL=glut
-GLUT_CONFIGURE_ENABLE= glut
-SDL_USE= SDL=sdl,image
-SDL_CONFIGURE_ENABLE= sdl sdlimage
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls