aboutsummaryrefslogtreecommitdiffstats
path: root/games/criticalmass/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/criticalmass/Makefile')
-rw-r--r--games/criticalmass/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 64f7e74d2969..a672ae195158 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -19,12 +19,6 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
SDL_image.10:${PORTSDIR}/graphics/sdl_image \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -34,6 +28,12 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${X11BASE}/lib" \
SDLINCPFILES= utilities/GLBitmapCollection.cpp utilities/GLExtension.hpp \
utilities/GLTexture.hpp utilities/PNG.hpp
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's#sdl-config#sdl11-config#; s#-lSDL # #;' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's#SDL/#SDL11/#;' ${SDLINCPFILES:S#^#${WRKSRC}/#}