aboutsummaryrefslogtreecommitdiffstats
path: root/games/crossfire-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/crossfire-server/Makefile')
-rw-r--r--games/crossfire-server/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index 8b5cf820b4bc..ec850aebd5bc 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= crossfire
-PORTVERSION= 1.4.0
+PORTVERSION= 1.5.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ifi.uio.no/pub/crossfire/ \
ftp://ftp.real-time.com/pub/games/crossfire/
MASTER_SITE_SUBDIR= crossfire
PKGNAMESUFFIX= -server
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
- ${PORTNAME}-${PORTVERSION}-maps.tar.gz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DISTNAME}.maps-big${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Server for multiplayer graphical arcade and adventure game
@@ -23,6 +23,8 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_XPM= yes
USE_PERL5= yes
+USE_OPENSSL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -31,6 +33,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
MAN6= crossfire.6 crossedit.6
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldes|-lcrypto|g' ${WRKSRC}/configure
+
post-install:
@${TAR} -C ${WRKDIR} -cf - maps | ${TAR} -C ${DATADIR} --unlink -xf -
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}