aboutsummaryrefslogtreecommitdiffstats
path: root/games/deng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/deng/Makefile')
-rw-r--r--games/deng/Makefile30
1 files changed, 11 insertions, 19 deletions
diff --git a/games/deng/Makefile b/games/deng/Makefile
index 7f14b25235e8..fa06a02058d9 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: deng
-# Date created: 25 Aug 2004
-# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
-#
+# Created by: Igor Pokrovsky <ip@doom.homeunix.org>
# $FreeBSD$
-#
PORTNAME= deng
PORTVERSION= 1.9.0b6.9
@@ -25,26 +21,26 @@ USE_LDCONFIG= yes
USE_SDL= sdl mixer net
USE_XORG= x11
USE_PYTHON= yes
-
-BUILDDIR= ${WRKSRC}/doomsday/portbuild
-BUILD_WRKSRC= ${BUILDDIR}
-INSTALL_WRKSRC= ${BUILDDIR}
-
USE_CMAKE= yes
+CMAKE_OUTSOURCE= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}/doomsday
CFLAGS+= -I${LOCALBASE}/include/libpng15
CMAKE_ARGS+= -DCMAKE_EXE_LINKER_FLAGS:STRING="-Wl,--export-dynamic"
MAN6= doomsday.6
-OPTIONS= OPENAL "Build OpenAL sound plugin" off
+OPTIONS_DEFINE= OPENAL DOCS
+OPTIONS_DEFAULT= DOCS
+OPENAL_DESC= Build OpenAL sound plugin
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENAL) || exists(${LOCALBASE}/lib/libopenal.so)
+.if ${PORT_OPTIONS:MOPENAL}
USE_OPENAL= al
CMAKE_ARGS+= -DBUILDOPENAL:BOOL=ON
PLIST_SUB= OPENAL=""
.else
+CMAKE_ARGS+= -DBUILDOPENAL:BOOL=OFF
PLIST_SUB= OPENAL="@comment "
.endif
@@ -54,18 +50,14 @@ post-patch:
-e '/TARGET_LINK_LIBRARIES/s/dl//' \
${WRKSRC}/doomsday/CMakeLists.txt
-do-configure:
- @${MKDIR} ${BUILDDIR}
- @cd ${BUILDDIR}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ..
-
post-install:
@${LN} -s ${PREFIX}/bin/doomsday ${PREFIX}/bin/deng
${INSTALL_MAN} ${WRKSRC}/doomsday/engine/doc/doomsday.6 ${MANPREFIX}/man/man6/
-.ifndef (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in LICENSE changelog.txt cnsname.txt cvars.txt deddoc.txt dhistory.txt naming.txt network.txt
${INSTALL_DATA} ${WRKSRC}/doomsday/engine/doc/${i} ${DOCSDIR}/
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>