aboutsummaryrefslogtreecommitdiffstats
path: root/games/domination/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/domination/Makefile')
-rw-r--r--games/domination/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/games/domination/Makefile b/games/domination/Makefile
index 27b464b8b517..3c7bcbebbf3b 100644
--- a/games/domination/Makefile
+++ b/games/domination/Makefile
@@ -1,7 +1,8 @@
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= domination
-PORTVERSION= 1.1.1.3
+PORTVERSION= 1.1.1.4
CATEGORIES= games java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/d/D/}/${PORTVERSION}/:game \
http://domination.sourceforge.net/maps/
@@ -14,8 +15,6 @@ COMMENT= Board game that is a bit like the well known game Risk
LICENSE= GPLv3
-OPTIONS_DEFINE= DOCS
-
FETCH_ARGS?= -Fpr
USE_ZIP= yes
USE_JAVA= yes
@@ -47,18 +46,11 @@ SUB_FILES= ${PORTNAME}-FlashGUI \
${PORTNAME}-SimpleGUI \
${PORTNAME}-SwingGUI
-DESKTOP_ENTRIES="Domination" "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
- "${PORTNAME}-SwingGUI" "Game;StrategyGame;" "false"
+DESKTOP_ENTRIES="Domination" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}-SwingGUI" "Game;StrategyGame;" false
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
-.endif
-
post-extract-script:
.for f in ${MAPS:S/$/.zip/}
@${UNZIP_CMD} -qo -d ${WRKSRC}/maps ${DISTDIR}/${DIST_SUBDIR}/${f}