aboutsummaryrefslogtreecommitdiffstats
path: root/games/el
diff options
context:
space:
mode:
Diffstat (limited to 'games/el')
-rw-r--r--games/el/Makefile3
-rw-r--r--games/el/files/patch-Makefile.bsd7
2 files changed, 6 insertions, 4 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index 10ab6882320e..524dfc3c2e5e 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -17,7 +17,8 @@ COMMENT= Eternal Lands is a free 3D MMORPG
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
vorbis.3:${PORTSDIR}/audio/libvorbis \
- cal3d.11:${PORTSDIR}/graphics/cal3d
+ cal3d.11:${PORTSDIR}/graphics/cal3d \
+ alut.0:${PORTSDIR}/audio/freealut
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
USE_GNOME= libxml2
diff --git a/games/el/files/patch-Makefile.bsd b/games/el/files/patch-Makefile.bsd
index 4c3036cd01d6..6b6f2ebfa36d 100644
--- a/games/el/files/patch-Makefile.bsd
+++ b/games/el/files/patch-Makefile.bsd
@@ -47,8 +47,8 @@
+CXXFLAGS=${CFLAGS} -fno-exceptions
.else
-CFLAGS=-Wdeclaration-after-statement -Wall -Werror -ggdb -pipe
-+CFLAGS+=-Wdeclaration-after-statement -Wall -Werror -ggdb -pipe
-+CXXFLAGS=-Wall -Wno-deprecated -Werror -ggdb -pipe -fno-exceptions
++CFLAGS+=-Wdeclaration-after-statement -ggdb -pipe
++CXXFLAGS=-ggdb -pipe -fno-exceptions
.endif
-CFLAGS+=-march=i686 -DBSD -DELC
-CFLAGS+=-I${X11BASE}/include `${SDL_CONFIG} --cflags`
@@ -59,7 +59,8 @@
+CFLAGS+=${CPPFLAGS}
+CXXFLAGS+=${CPPFLAGS}
LDFLAGS+=-L${X11BASE}/lib -lGL `${SDL_CONFIG} --libs` `${LIBXML2_CONFIG} --libs`
- LDFLAGS+=-L${LOCALBASE}/lib -lSDL_net -lopenal -lGLU -lvorbis -lvorbisfile -lm
+-LDFLAGS+=-L${LOCALBASE}/lib -lSDL_net -lopenal -lGLU -lvorbis -lvorbisfile -lm
++LDFLAGS+=-L${LOCALBASE}/lib -lSDL_net -lopenal -lalut -lGLU -lvorbis -lvorbisfile -lm
.if CAL3D
-SRCS+=cal3dwrap.c
+SRCS+=cal3d_wrapper.cpp