aboutsummaryrefslogtreecommitdiffstats
path: root/games/etracer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/etracer/Makefile')
-rw-r--r--games/etracer/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/games/etracer/Makefile b/games/etracer/Makefile
index 4ee2b16c6b98..a74add3c28f2 100644
--- a/games/etracer/Makefile
+++ b/games/etracer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= etracer
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/extremetuxracer
DISTNAME= extremetuxracer-${PORTVERSION}
@@ -15,17 +15,20 @@ DISTNAME= extremetuxracer-${PORTVERSION}
MAINTAINER= peter_dunning@dsl.pipex.com
COMMENT= The latest and greatest fork of the classic Tux Racer
-LIB_DEPENDS= tcl85:${PORTSDIR}/lang/tcl85 \
- png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
USE_SDL= mixer sdl
USE_GL= gl glu glut
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.5 \
- --with-tcl-inc=${PREFIX}/include/tcl8.5 \
+
+USE_TCL= 84+
+
+.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --with-tcl="${TCL_LIBDIR}" \
+ --with-tcl-inc="${TCL_INCLUDEDIR}" \
--with-gl-libs="${LOCALBASE}/lib" \
--with-gl-inc="${LOCALBASE}/include"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>