aboutsummaryrefslogtreecommitdiffstats
path: root/games/flightgear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/flightgear/Makefile')
-rw-r--r--games/flightgear/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index e110f63a6d3e..8b8da66e6191 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= FlightGear
PORTVERSION?= ${FGVERSION}
-PORTREVISION= 1
+PORTREVISION?= 0
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= ftp://ftp.de.flightgear.org/pub/fgfs/Source/ \
@@ -22,14 +22,16 @@ MASTER_SITES= ftp://ftp.de.flightgear.org/pub/fgfs/Source/ \
MAINTAINER?= ganael.laplanche@martymac.com
COMMENT?= The FlightGear flight simulator
-LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
+ osg.48:${PORTSDIR}/graphics/osg \
+ boost_thread.4:${PORTSDIR}/devel/boost
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/FlightGear/version:${PORTSDIR}/games/flightgear-data
-FGVERSION= 1.9.0
+FGVERSION= 1.9.1
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut