aboutsummaryrefslogtreecommitdiffstats
path: root/games/flightgear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/flightgear/Makefile')
-rw-r--r--games/flightgear/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 5d16ec5d7e91..2852beed6f88 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -40,6 +40,12 @@ CONFIGURE_ARGS= --with-threads
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -53,4 +59,4 @@ do-install:
@(cd ${WRKSRC}/data && ${FIND} . -type f |\
${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>