aboutsummaryrefslogtreecommitdiffstats
path: root/games/flying
diff options
context:
space:
mode:
Diffstat (limited to 'games/flying')
-rw-r--r--games/flying/Makefile24
-rw-r--r--games/flying/distinfo1
-rw-r--r--games/flying/files/patch-aa19
-rw-r--r--games/flying/pkg-comment1
-rw-r--r--games/flying/pkg-descr5
-rw-r--r--games/flying/pkg-plist2
6 files changed, 52 insertions, 0 deletions
diff --git a/games/flying/Makefile b/games/flying/Makefile
new file mode 100644
index 000000000000..44151b4367bd
--- /dev/null
+++ b/games/flying/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: flying-6.20
+# Version required: 6.20
+# Date created: 12 Jul 1996
+# Whom: searle
+#
+# $Id$
+#
+
+DISTNAME= flying-6.20
+CATEGORIES+= games
+MASTER_SITES= ftp://fsuj01.rz.uni-jena.de/pub/linux/MIRROR.sunsite/games/x11/ \
+ ftp://dei.unipd.it/linux/sunsite/games/x11/ \
+ ftp://pippen.bl.physik.tu-muenchen.de/pub/comp/os/linux/sunsite/games/x11/ \
+ ftp://nic.switch.ch/mirror/linux/sunsite.games/x11/ \
+ ftp://unix.hensa.ac.uk/mirrors/sunsite/pub/Linux/games/x11/ \
+ ftp://sunsite.rediris.es/software/linux/sunsite/games/x11/ \
+ ftp://fvkma.tu-graz.ac.at/.2/x11/R6contrib/games/multiplayer/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= searle@longacre.demon.co.uk
+
+USE_IMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/games/flying/distinfo b/games/flying/distinfo
new file mode 100644
index 000000000000..beb602464d5a
--- /dev/null
+++ b/games/flying/distinfo
@@ -0,0 +1 @@
+MD5 (flying-6.20.tgz) = e237573f5dd883f704dbd8454320ad8b
diff --git a/games/flying/files/patch-aa b/games/flying/files/patch-aa
new file mode 100644
index 000000000000..4b3bb56f9a8a
--- /dev/null
+++ b/games/flying/files/patch-aa
@@ -0,0 +1,19 @@
+--- Imakefile.orig Tue Oct 3 16:01:36 1995
++++ Imakefile Wed Aug 7 20:53:56 1996
+@@ -1,6 +1,6 @@
+
+ XCOMM ##### where to put temporary data and pixmap files ...
+-DATA_DIRECTORY = \"/tmp\"
++DATA_DIRECTORY = \"/dev/null\"
+
+ XCOMM ##### parameter type of the system call select(), which usually is
+ XCOMM ##### fd_set, but at least on HP-UX, it is int ... I am still
+@@ -30,7 +30,7 @@
+ CCOPTIONS = #-Wall -g
+
+ LOCAL_LIBRARIES = -lX11 -lm
+-
++all: flying
+ flying: $(OBJS) $(DEPLIBS)
+ $(RM) $@
+ $(CXX) -o $@ $(OBJS) $(LDOPTIONS) $(LOCAL_LIBRARIES) $(LDLIBS) $(EXTRA_LOAD_FLAGS)
diff --git a/games/flying/pkg-comment b/games/flying/pkg-comment
new file mode 100644
index 000000000000..eab40de06dd8
--- /dev/null
+++ b/games/flying/pkg-comment
@@ -0,0 +1 @@
+Pool/snooker/billiards/carrom/etc game.
diff --git a/games/flying/pkg-descr b/games/flying/pkg-descr
new file mode 100644
index 000000000000..61543c322cb7
--- /dev/null
+++ b/games/flying/pkg-descr
@@ -0,0 +1,5 @@
+Flying is pool, snooker, carrom, hockey + curling with nice animated spinning
+balls for pool.
+
+Michael Searle
+searle@longacre.demon.co.uk
diff --git a/games/flying/pkg-plist b/games/flying/pkg-plist
new file mode 100644
index 000000000000..510642b9c4d8
--- /dev/null
+++ b/games/flying/pkg-plist
@@ -0,0 +1,2 @@
+bin/flying
+man/man1/flying.1.gz