aboutsummaryrefslogtreecommitdiffstats
path: root/games/freebsd-games/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/freebsd-games/Makefile')
-rw-r--r--games/freebsd-games/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/freebsd-games/Makefile b/games/freebsd-games/Makefile
index 89c6ced4dee6..b42c67c5ca3a 100644
--- a/games/freebsd-games/Makefile
+++ b/games/freebsd-games/Makefile
@@ -57,6 +57,12 @@ PATHNAME_FILES= atc/atc.6 \
quiz/quiz.6 \
wump/pathnames.h
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-extract:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} extract)
@@ -74,4 +80,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
"${WRKSRC}/hack/hack.unix.c"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>