aboutsummaryrefslogtreecommitdiffstats
path: root/games/freedink-engine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/freedink-engine/Makefile')
-rw-r--r--games/freedink-engine/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/games/freedink-engine/Makefile b/games/freedink-engine/Makefile
index 8361250bb5b8..07cba95cbdd2 100644
--- a/games/freedink-engine/Makefile
+++ b/games/freedink-engine/Makefile
@@ -1,9 +1,8 @@
-# Created by: shurd
+# Created by: Stephen Hurd <shurd@sasktel.net>
# $FreeBSD$
PORTNAME= freedink
PORTVERSION= 1.08.${PORTVER}
-PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= freedink
@@ -12,12 +11,12 @@ PKGNAMESUFFIX= -engine
MAINTAINER= shurd@sasktel.net
COMMENT= Dink Smallwood RPG and RPG Construction Set
-LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
-USE_GMAKE= yes
+USES= gettext gmake
USE_SDL= sdl gfx ttf image mixer
GNU_CONFIGURE= yes
-PORTVER= 20080920
+PORTVER= 20121209
CONFIGURE_ARGS= --disable-static --disable-upx
MAN6= freedink.6 freedinkedit.6 dink.6 dinkedit.6
@@ -27,12 +26,15 @@ EMBEDDED_DESC= Embedded Resources
OPTIONS_DEFAULT= EMBEDDED
+post-patch:
+ @${CHMOD} 0755 ${WRKSRC}/autotools/install-reloc
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEMBEDDED}
CONFIGURE_ARGS+= --enable-embedded-resources
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS+= zip.3:${PORTSDIR}/archivers/libzip
+LIB_DEPENDS+= zip:${PORTSDIR}/archivers/libzip
RUN_DEPENDS+= zip:${PORTSDIR}/archivers/zip
.else
CONFIGURE_ARGS+= --disable-embedded-resources