aboutsummaryrefslogtreecommitdiffstats
path: root/games/freedoko
diff options
context:
space:
mode:
Diffstat (limited to 'games/freedoko')
-rw-r--r--games/freedoko/Makefile24
-rw-r--r--games/freedoko/distinfo6
-rw-r--r--games/freedoko/files/patch-ui-gtkmm-icongroup.cpp18
-rw-r--r--games/freedoko/files/patch-ui-help.cpp171
-rw-r--r--games/freedoko/pkg-plist90
5 files changed, 52 insertions, 257 deletions
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index a4e72fc1ed22..43134d151933 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freedoko
-PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTVERSION= 0.7.2b
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= free-doko
@@ -16,41 +15,28 @@ DISTNAME= FreeDoko_${PORTVERSION}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Play the card game Doppelkopf
-LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
- gnet-2.0.0:${PORTSDIR}/net/gnet2
+LIB_DEPENDS= gnet-2.0.0:${PORTSDIR}/net/gnet2 \
+ gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
WRKSRC= ${WRKDIR}/${DISTNAME:C/\.src$//}/src
USE_ZIP= yes
USE_GCC= 3.4+
-USE_REINPLACE= yes
USE_GMAKE= yes
-MAKE_ENV= OSTYPE=linux-gnu DATADIR=${DATADIR}
-
-BROKEN= "Requires update for gtkmm 2.8"
+MAKE_ENV= OS="${OPSYS}" DATADIR="${DATADIR}"
post-patch:
@${FIND} ${WRKSRC} -name "*Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
's|\.\./data|$$(DATADIR)|g ; \
- s|gtkmm-2.0|gtkmm-2.4|g ; \
s|@echo $$(CXX)|@true $$(CXX)|g ; \
s|@$$(CXX)|$$(CXX)|g ; \
s|make -C|$$(MAKE) -C|g'
- @${REINPLACE_CMD} -e \
- 's|SigC::slot|sigc::ptr_fun|g' ${WRKSRC}/ui/gtkmm/utils.cpp
- @${FIND} ${WRKSRC}/ui/gtkmm -name "*.cpp" -or -name "*.h" | \
- ${XARGS} ${REINPLACE_CMD} -e \
- 's|SigC::Object|sigc::trackable|g ; \
- s|SigC::slot|sigc::mem_fun|g ; \
- s|SigC::Connection|sigc::connection|g ; \
- s|SigC::Slot|sigc::slot|g ; \
- s|SigC|sigc|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/FreeDoko ${PREFIX}/bin
${LN} -sf FreeDoko ${PREFIX}/bin/freedoko
@${MKDIR} ${DATADIR}
-.for dir in ai backgrounds cardsets rules translations
+.for dir in backgrounds cardsets rules translations
@cd ${WRKSRC}/../data && ${FIND} ${dir} ! -name "*Makefile*" | \
${CPIO} --quiet -pdum -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
.endfor
diff --git a/games/freedoko/distinfo b/games/freedoko/distinfo
index 582ec706553e..6980e90118ea 100644
--- a/games/freedoko/distinfo
+++ b/games/freedoko/distinfo
@@ -1,3 +1,3 @@
-MD5 (FreeDoko_0.7.0.src.zip) = e285266ef30c02e0f82dae79a938ade6
-SHA256 (FreeDoko_0.7.0.src.zip) = 7fa02dac00a370ba4f763b9328291ffe634d4637c65626919002fef5e2ed58af
-SIZE (FreeDoko_0.7.0.src.zip) = 7668449
+MD5 (FreeDoko_0.7.2b.src.zip) = 500f713d455bd171e439c9118f63e865
+SHA256 (FreeDoko_0.7.2b.src.zip) = 86d466f578af4252e01a946abca50215acb6c57093587e159b13e935aad1cc34
+SIZE (FreeDoko_0.7.2b.src.zip) = 7756056
diff --git a/games/freedoko/files/patch-ui-gtkmm-icongroup.cpp b/games/freedoko/files/patch-ui-gtkmm-icongroup.cpp
deleted file mode 100644
index a39a65c776c9..000000000000
--- a/games/freedoko/files/patch-ui-gtkmm-icongroup.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- ui/gtkmm/icongroup.cpp.orig Sun Aug 21 15:51:54 2005
-+++ ui/gtkmm/icongroup.cpp Fri Sep 16 07:37:05 2005
-@@ -218,6 +218,7 @@
- << endl;
- }
- #endif
-+#if 0
- if (icon.is_null()
- && ::setting(Setting::SHOW_AI_INFORMATION_TEAMS)
- && (game.humanno() == 1)
-@@ -228,6 +229,7 @@
- icon->saturate_and_pixelate(copy, 5, true);
- icon = copy;
- } // if (icon.is_null())
-+#endif
-
- if (icon)
- possible_icons.push_back(icon);
diff --git a/games/freedoko/files/patch-ui-help.cpp b/games/freedoko/files/patch-ui-help.cpp
deleted file mode 100644
index 1c700548a732..000000000000
--- a/games/freedoko/files/patch-ui-help.cpp
+++ /dev/null
@@ -1,171 +0,0 @@
---- ui/help.cpp.orig Sun Aug 7 15:59:22 2005
-+++ ui/help.cpp Wed Sep 14 18:56:54 2005
-@@ -49,7 +49,7 @@
- **
- **/
- string
-- Help::manual_directory()
-+ manual_directory()
- {
- vector<string> directory;
-
-@@ -132,7 +132,7 @@
- return ("http://free-doko.sourceforge.net/"
- + ::setting(Setting::HELP_DIRECTORY) + "/"
- + ::setting(Setting::LANGUAGE) + "/");
-- } // string Help::manual_directory()
-+ } // string manual_directory()
-
- /**
- ** -> result
-@@ -147,10 +147,10 @@
- **
- **/
- string
-- Help::operation_directory()
-+ operation_directory()
- {
- return (manual_directory() + "operation/");
-- } // string Help::operation_directory()
-+ } // string operation_directory()
-
- /**
- ** show the help page of the given location
-@@ -165,7 +165,7 @@
- **
- **/
- void
-- Help::show(string const location)
-+ show(string const location)
- {
- #ifndef WINDOWS
- ::system((::setting(Setting::BROWSER) + " " + location + " &").c_str());
-@@ -174,7 +174,7 @@
- #endif
-
- return ;
-- } // void Help::show(string const location)
-+ } // void show(string const location)
-
- /**
- ** show the manual help page of the given location
-@@ -189,12 +189,12 @@
- **
- **/
- void
-- Help::show_manual(string const page)
-+ show_manual(string const page)
- {
- show(manual_directory() + page + ".html");
-
- return ;
-- } // void Help::show_manual(string const page)
-+ } // void show_manual(string const page)
-
- /**
- ** show the operation help page of the given location
-@@ -209,12 +209,12 @@
- **
- **/
- void
-- Help::show_operation(string const page)
-+ show_operation(string const page)
- {
- show(operation_directory() + page + ".html");
-
- return ;
-- } // void Help::show_operation(string const page)
-+ } // void show_operation(string const page)
-
- /**
- ** shows the help for 'game_status'
-@@ -231,10 +231,10 @@
- **
- **/
- void
-- Help::show(GameStatus const game_status)
-+ show(GameStatus const game_status)
- {
- return ;
-- } // void Help::show(GameStatus const game_status)
-+ } // void show(GameStatus const game_status)
-
- /**
- ** shows the help for the rule 'type'
-@@ -251,10 +251,10 @@
- **
- **/
- void
-- Help::show(Rule::TypeBool const type)
-+ show(Rule::TypeBool const type)
- {
- return ;
-- } // void Help::show(Rule::TypeBool const type)
-+ } // void show(Rule::TypeBool const type)
-
- /**
- ** shows the help for the rule 'type'
-@@ -271,10 +271,10 @@
- **
- **/
- void
-- Help::show(Rule::TypeUnsigned const type)
-+ show(Rule::TypeUnsigned const type)
- {
- return ;
-- } // void Help::show(Rule::TypeUnsigned const type)
-+ } // void show(Rule::TypeUnsigned const type)
-
- /**
- ** shows the help for the setting 'type'
-@@ -291,10 +291,10 @@
- **
- **/
- void
-- Help::show(Setting::TypeBool const type)
-+ show(Setting::TypeBool const type)
- {
- return ;
-- } // void Help::show(Setting::TypeBool const type)
-+ } // void show(Setting::TypeBool const type)
-
- /**
- ** shows the help for the setting 'type'
-@@ -311,10 +311,10 @@
- **
- **/
- void
-- Help::show(Setting::TypeUnsigned const type)
-+ show(Setting::TypeUnsigned const type)
- {
- return ;
-- } // void Help::show(Setting::TypeUnsigned const type)
-+ } // void show(Setting::TypeUnsigned const type)
-
- /**
- ** shows the help for the setting 'type'
-@@ -331,10 +331,10 @@
- **
- **/
- void
-- Help::show(Setting::TypeString const type)
-+ show(Setting::TypeString const type)
- {
- return ;
-- } // void Help::show(Setting::TypeString const type)
-+ } // void show(Setting::TypeString const type)
-
- /**
- ** shows the help for the setting 'type'
-@@ -351,9 +351,9 @@
- **
- **/
- void
-- Help::show(Setting::TypeCardsOrder const type)
-+ show(Setting::TypeCardsOrder const type)
- {
- return ;
-- } // void Help::show(Setting::TypeCardsOrder const type)
-+ } // void show(Setting::TypeCardsOrder const type)
-
- } // namespace Help
diff --git a/games/freedoko/pkg-plist b/games/freedoko/pkg-plist
index d2243b58bde6..8fb8810ad125 100644
--- a/games/freedoko/pkg-plist
+++ b/games/freedoko/pkg-plist
@@ -7,45 +7,31 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/Implementation/Zugriff.html
%%PORTDOCS%%%%DOCSDIR%%/Roadmap
%%PORTDOCS%%%%DOCSDIR%%/de/DDV_Kurzregeln.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/DDV_Kurzregeln.tex
%%PORTDOCS%%%%DOCSDIR%%/de/DDV_Turnierregeln.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/Dateien.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/Dateien.txt
-%%PORTDOCS%%%%DOCSDIR%%/de/Einfuehrung.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/Einfuehrung.txt
-%%PORTDOCS%%%%DOCSDIR%%/de/FAQ.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/FAQ.txt
-%%PORTDOCS%%%%DOCSDIR%%/de/Fehler.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/Fehler.txt
+%%PORTDOCS%%%%DOCSDIR%%/de/DDV_Turnierregeln.tex
+%%PORTDOCS%%%%DOCSDIR%%/de/FreeDoko_Konzept.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/FreeDoko_Konzept.tex
+%%PORTDOCS%%%%DOCSDIR%%/de/FreeDoko_Regeln.pdf
+%%PORTDOCS%%%%DOCSDIR%%/de/FreeDoko_Regeln.tex
%%PORTDOCS%%%%DOCSDIR%%/de/GPL.de
-%%PORTDOCS%%%%DOCSDIR%%/de/Konfiguration.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/Konfiguration.txt
%%PORTDOCS%%%%DOCSDIR%%/de/Kurzregeln.pdf
%%PORTDOCS%%%%DOCSDIR%%/de/Kurzregeln.tex
-%%PORTDOCS%%%%DOCSDIR%%/de/Kurzregeln.txt
-%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.SuSE
-%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.Windows
-%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.gtkmm_2.4
%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.html
%%PORTDOCS%%%%DOCSDIR%%/de/LIESMICH.txt
-%%PORTDOCS%%%%DOCSDIR%%/de/MinGW32.txt
-%%PORTDOCS%%%%DOCSDIR%%/de/Planung.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/Planung.txt
-%%PORTDOCS%%%%DOCSDIR%%/de/Regeln.pdf
-%%PORTDOCS%%%%DOCSDIR%%/de/Regeln.txt
-%%PORTDOCS%%%%DOCSDIR%%/en/FAQ.pdf
-%%PORTDOCS%%%%DOCSDIR%%/en/FAQ.txt
-%%PORTDOCS%%%%DOCSDIR%%/en/README.Windows
+%%PORTDOCS%%%%DOCSDIR%%/de/SuSE
+%%PORTDOCS%%%%DOCSDIR%%/de/Windows
+%%PORTDOCS%%%%DOCSDIR%%/de/compiling.Windows
+%%PORTDOCS%%%%DOCSDIR%%/de/subversion
+%%PORTDOCS%%%%DOCSDIR%%/en/FreeDoko_concept.pdf
+%%PORTDOCS%%%%DOCSDIR%%/en/FreeDoko_concept.tex
+%%PORTDOCS%%%%DOCSDIR%%/en/FreeDoko_rules.pdf
+%%PORTDOCS%%%%DOCSDIR%%/en/FreeDoko_rules.tex
%%PORTDOCS%%%%DOCSDIR%%/en/README.html
%%PORTDOCS%%%%DOCSDIR%%/en/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/en/configuration.pdf
-%%PORTDOCS%%%%DOCSDIR%%/en/configuration.txt
-%%PORTDOCS%%%%DOCSDIR%%/en/introduction.pdf
-%%PORTDOCS%%%%DOCSDIR%%/en/introduction.txt
-%%PORTDOCS%%%%DOCSDIR%%/en/rules.pdf
-%%PORTDOCS%%%%DOCSDIR%%/en/rules.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/Windows
%%PORTDOCS%%%%DOCSDIR%%/en/shortrules.pdf
%%PORTDOCS%%%%DOCSDIR%%/en/shortrules.tex
-%%PORTDOCS%%%%DOCSDIR%%/en/shortrules.txt
%%PORTDOCS%%%%DOCSDIR%%/hpux.required_libs.txt
%%PORTDOCS%%%%DOCSDIR%%/manual/de/bugs.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/configuration.html
@@ -55,6 +41,7 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/de/index.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/installation.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/network_protocol.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/_template.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/ai_config.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/bug_report.html
@@ -65,46 +52,59 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/keys.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/last_trick.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/menu.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/network_config.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/overview.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/party_finished.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/party_points.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/party_settings.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/about.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/about.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/bug_report.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/cardset_license.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/cardset_license.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/changelog.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/changelog.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/current_trick.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/current_trick.small.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/full_trick.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/generate_error.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/generate_error.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/last_trick.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/last_trick.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/license.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/license.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/main_window.game.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/main_window.game.small.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/main_window.start.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/main_window.start.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/party_points.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/party_points.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/party_settings.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/party_settings.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/player_config.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/player_config.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/reservation.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/reservation.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/reservation.solo.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/reservation.solo.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/announcements.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/announcements.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/announcements.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/dollen.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/dollen.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/dollen.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/informations.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/informations.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/informations.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/marriage.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/marriage.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/marriage.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/poverty.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/poverty.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/poverty.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/solo.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/solo.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/solo.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/specialpoints.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/specialpoints.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/specialpoints.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/swines.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/swines.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/swines.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/tournament.png
-%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/tournament.small.png
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/rules/tournament.small.jpg
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/splash.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/contra.png
%%PORTDOCS%%%%DOCSDIR%%/manual/de/operation/pictures/symbols/five_nines.png
@@ -179,6 +179,7 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/de/shortrules.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/shortrules.ps
%%PORTDOCS%%%%DOCSDIR%%/manual/de/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/de/toc.short.html
%%PORTDOCS%%%%DOCSDIR%%/manual/de/todo.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/configuration.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/credits.html
@@ -186,6 +187,7 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/en/index.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/introduction.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/operation/ai_config.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/operation/index.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/operation/overview.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/overview.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/rules.html
@@ -198,13 +200,6 @@ bin/freedoko
%%PORTDOCS%%%%DOCSDIR%%/manual/pictures/FreeDoko.icon.png
%%PORTDOCS%%%%DOCSDIR%%/manual/pictures/flags/de.gif
%%PORTDOCS%%%%DOCSDIR%%/manual/pictures/flags/gb.gif
-%%DATADIR%%/ai/normal
-%%DATADIR%%/ai/normal.pro
-%%DATADIR%%/ai/novice
-%%DATADIR%%/ai/novice.pro
-%%DATADIR%%/ai/profi
-%%DATADIR%%/ai/profi.pro
-%%DATADIR%%/ai/standard
%%DATADIR%%/backgrounds/table.png
%%DATADIR%%/cardsets/Altenburg/License
%%DATADIR%%/cardsets/Altenburg/french/backs/penguin.png
@@ -304,6 +299,7 @@ bin/freedoko
%%DATADIR%%/translations/de/text.bug_report
%%DATADIR%%/translations/de/text.cards
%%DATADIR%%/translations/de/text.chat
+%%DATADIR%%/translations/de/text.gtkmm.menu
%%DATADIR%%/translations/de/text.gui
%%DATADIR%%/translations/de/text.help
%%DATADIR%%/translations/de/text.menu
@@ -312,12 +308,14 @@ bin/freedoko
%%DATADIR%%/translations/de/text.rules
%%DATADIR%%/translations/de/text.settings
%%DATADIR%%/translations/de/text.versions
+%%DATADIR%%/translations/de-alt/text
%%DATADIR%%/translations/en/text
%%DATADIR%%/translations/en/text.aiconfig
%%DATADIR%%/translations/en/text.basistypes
%%DATADIR%%/translations/en/text.bug_report
%%DATADIR%%/translations/en/text.cards
%%DATADIR%%/translations/en/text.chat
+%%DATADIR%%/translations/en/text.gtkmm.menu
%%DATADIR%%/translations/en/text.gui
%%DATADIR%%/translations/en/text.help
%%DATADIR%%/translations/en/text.menu
@@ -327,6 +325,7 @@ bin/freedoko
%%DATADIR%%/translations/en/text.settings
%%DATADIR%%/translations/en/text.versions
@dirrm %%DATADIR%%/translations/en
+@dirrm %%DATADIR%%/translations/de-alt
@dirrm %%DATADIR%%/translations/de
@dirrm %%DATADIR%%/translations
@dirrm %%DATADIR%%/rules
@@ -341,7 +340,6 @@ bin/freedoko
@dirrm %%DATADIR%%/cardsets/Altenburg
@dirrm %%DATADIR%%/cardsets
@dirrm %%DATADIR%%/backgrounds
-@dirrm %%DATADIR%%/ai
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/pictures/flags
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/pictures