aboutsummaryrefslogtreecommitdiffstats
path: root/games/frotz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/frotz/Makefile')
-rw-r--r--games/frotz/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/games/frotz/Makefile b/games/frotz/Makefile
index c09534b0af34..948856391d34 100644
--- a/games/frotz/Makefile
+++ b/games/frotz/Makefile
@@ -5,27 +5,25 @@
# $FreeBSD$
#
-PORTNAME= frotz
-PORTVERSION= 2.32
-CATEGORIES= games
-MASTER_SITES= ftp://ftp.gmd.de/if-archive/infocom/interpreters/frotz/
-DISTNAME= UnixFrotz232R2Std10
+PORTNAME= frotz
+PORTVERSION= 2.40
+CATEGORIES= games
+MASTER_SITES= http://www.cs.csubak.edu/~dgriffi/frotz/files/ \
+ ftp://ftp.gmd.de/if-archive/infocom/interpreters/frotz/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-ALL_TARGET=
-WRKSRC= ${WRKDIR}/frotz-2.32
+ALL_TARGET= # empty
-MAN6= frotz.6
+MAN6= frotz.6
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/frotz.6 ${PREFIX}/man/man6
-
+ ${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/frotz.6 ${PREFIX}/man/man6
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/frotz
-.for file in Readme.unix Todo
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/frotz
+ @${MKDIR} ${PREFIX}/share/doc/frotz
+.for file in AUTHORS BUGS ChangeLog HOW_TO_PLAY INSTALL README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/frotz
.endfor
.endif