aboutsummaryrefslogtreecommitdiffstats
path: root/games/gcompris2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gcompris2/Makefile')
-rw-r--r--games/gcompris2/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/games/gcompris2/Makefile b/games/gcompris2/Makefile
index 1feb76fecf54..bf2e734ab786 100644
--- a/games/gcompris2/Makefile
+++ b/games/gcompris2/Makefile
@@ -19,17 +19,15 @@ RUN_DEPENDS= ogg123:${PORTSDIR}/audio/vorbis-tools
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs gdkpixbuf
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
+post-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
.include <bsd.port.mk>