aboutsummaryrefslogtreecommitdiffstats
path: root/games/gl-117
diff options
context:
space:
mode:
Diffstat (limited to 'games/gl-117')
-rw-r--r--games/gl-117/Makefile20
-rw-r--r--games/gl-117/pkg-plist2
2 files changed, 20 insertions, 2 deletions
diff --git a/games/gl-117/Makefile b/games/gl-117/Makefile
index 0a73fa6f64da..3548791b2630 100644
--- a/games/gl-117/Makefile
+++ b/games/gl-117/Makefile
@@ -8,10 +8,10 @@
PORTNAME= gl-117
PORTVERSION= 1.3.2
-PORTREVISION= 5
+DISTVERSIONSUFFIX= -src
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/GL-117%20Source
-DISTVERSIONSUFFIX= -src
MAINTAINER= erik@smluc.org
COMMENT= An OpenGL & SDL action flight simulator
@@ -23,4 +23,20 @@ CONFIGURE_ARGS= --with-opengl-dir=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+DESKTOP_ENTRIES= "GL-117" \
+ "Action flight simulator" \
+ "" \
+ "gl-117" \
+ "Game;ArcadeGame;" \
+ false
+
+MAN6= gl-117.6
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/gl-117.6 ${MANPREFIX}/man/man6
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/gl-117.pdf ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/games/gl-117/pkg-plist b/games/gl-117/pkg-plist
index be493a7d8af3..feb9ec9f866a 100644
--- a/games/gl-117/pkg-plist
+++ b/games/gl-117/pkg-plist
@@ -1,4 +1,5 @@
bin/gl-117
+%%PORTDOCS%%%%DOCSDIR%%/gl-117.pdf
%%DATADIR%%/models/aster1.3ds
%%DATADIR%%/models/barrier.3ds
%%DATADIR%%/models/base1.3ds
@@ -167,3 +168,4 @@ bin/gl-117
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/textures
@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%