aboutsummaryrefslogtreecommitdiffstats
path: root/games/glob2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/glob2/Makefile')
-rw-r--r--games/glob2/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index 2854e0e71a6e..0e75c70a4552 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -26,15 +26,13 @@ USE_SDL= image net sdl ttf
USE_GL= gl glu
MAKE_ARGS= CCFLAGS="${CFLAGS}" \
LINKFLAGS="${LDFLAGS}" \
- LIBPATH="${LIBPATH}" \
BINDIR="${STAGEDIR}${PREFIX}/bin" \
INSTALLDIR="${STAGEDIR}${PREFIX}/share" \
DATADIR="${DATADIR}"
INSTALLS_ICONS= yes
-CFLAGS+= ${PA2_CFLAGS} -I${LOCALBASE}/include -Wno-return-type
-LDFLAGS+= -lpthread ${PA2_LDFLAGS} -L${LOCALBASE}/lib
-LIBPATH= ${LIBPATH2}${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include -Wno-return-type
+LDFLAGS+= -lpthread -L${LOCALBASE}/lib
PORTDOCS= README
SUB_FILES= pkg-message
@@ -42,10 +40,7 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPORTAUDIO}
-LIB_DEPENDS+= libportaudio.so.2:${PORTSDIR}/audio/portaudio2
-PA2_CFLAGS+= -I${LOCALBASE}/include/portaudio2
-PA2_LDFLAGS+= -L${LOCALBASE}/lib/portaudio2
-LIBPATH2= ${LOCALBASE}/lib/portaudio2:
+LIB_DEPENDS+= libportaudio.so:${PORTSDIR}/audio/portaudio
MAKE_ARGS+= --portaudio=true
.else
MAKE_ARGS+= --portaudio=false
@@ -56,9 +51,6 @@ pre-configure:
's|"-g"|""|' \
${WRKSRC}/SConstruct
${REINPLACE_CMD} -e \
- 's|portaudio.h|portaudio2/portaudio.h|' \
- ${WRKSRC}/src/VoiceRecorder.cpp
- ${REINPLACE_CMD} -e \
'/^Icon/s|=.*|=${PORTNAME}|' \
${WRKSRC}/data/${PORTNAME}.desktop
${REINPLACE_CMD} -e \