aboutsummaryrefslogtreecommitdiffstats
path: root/games/glob2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/glob2/Makefile')
-rw-r--r--games/glob2/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
new file mode 100644
index 000000000000..a03e40b69671
--- /dev/null
+++ b/games/glob2/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: glob2
+# Date created: Wed 21 apr 2004
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= glob2
+PORTVERSION= 0.8.5
+CATEGORIES= games
+MASTER_SITES= http://www.ysagoon.com/glob2/data/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Globulation 2 - a free and innovative strategy game
+
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
+ freetype.9:${PORTSDIR}/print/freetype2
+
+USE_SDL= image net sdl
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+USE_GCC= 3.3
+
+PLIST_FILES= bin/glob2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/glob2 ${PREFIX}/bin
+
+.include <bsd.port.mk>