aboutsummaryrefslogtreecommitdiffstats
path: root/games/gltron/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gltron/Makefile')
-rw-r--r--games/gltron/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index deadd4746e93..c1427f5704e4 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: gltron
-# Version required: 0.46
+# Version required: 0.53
# Date created: 24 July 1999
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
-DISTNAME= glTron-0.46
-PKGNAME= gltron-0.46
+DISTNAME= gltron-0.53
CATEGORIES= games
MASTER_SITES= http://www.ards.net/Andreas/gltron/
@@ -18,15 +17,21 @@ LIB_DEPENDS= MesaGL.14:${PORTSDIR}/graphics/Mesa3 \
glut.3:${PORTSDIR}/graphics/Mesa3
USE_X_PREFIX= yes
+USE_GMAKE= yes
+MAKE_ENV+= OPT="${CFLAGS}"
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/gltron ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/gltron/
+.for FILE in *.sgi *.txt t-u-low.obj tron.mtl xenotron.ftx
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/share/gltron/
+.endfor
+ @${INSTALL_PROGRAM} ${WRKSRC}/gltron ${PREFIX}/bin
post-install:
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/gltron
+ @${MKDIR} ${PREFIX}/share/doc/gltron
.for file in CHANGELOG CREDITS README
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gltron
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gltron
.endfor
.endif