aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnuchess/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnuchess/Makefile')
-rw-r--r--games/gnuchess/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/games/gnuchess/Makefile b/games/gnuchess/Makefile
index e845be3a7fac..ccbe41dab7c1 100644
--- a/games/gnuchess/Makefile
+++ b/games/gnuchess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnuchess
-PORTVERSION= 5.05
+PORTVERSION= 5.06
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= chess
@@ -14,7 +14,13 @@ MASTER_SITE_SUBDIR= chess
MAINTAINER= ports@FreeBSD.org
COMMENT= "Classic" Gnu Chess
-WRKSRC= ${WRKDIR}/chess
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS:S/"//g}|g ; \
+ s|-pthread ||g' ${WRKSRC}/configure
.include <bsd.port.mk>