aboutsummaryrefslogtreecommitdiffstats
path: root/games/gottet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gottet/Makefile')
-rw-r--r--games/gottet/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/games/gottet/Makefile b/games/gottet/Makefile
index e89f333d032d..4395e952f768 100644
--- a/games/gottet/Makefile
+++ b/games/gottet/Makefile
@@ -20,9 +20,20 @@ INSTALLS_ICONS= yes
PORTDOCS= CREDITS ChangeLog
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -i '' '/qm.files/,/qm.path/s/^/#/' \
+ ${WRKSRC}/${PORTNAME}.pro
+.endif
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/