aboutsummaryrefslogtreecommitdiffstats
path: root/games/gottet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gottet/Makefile')
-rw-r--r--games/gottet/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/games/gottet/Makefile b/games/gottet/Makefile
index 6802a697df00..c17243ad82d4 100644
--- a/games/gottet/Makefile
+++ b/games/gottet/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gottet
-PORTVERSION= 1.1.1
+PORTVERSION= 1.1.3
DISTVERSIONSUFFIX= -src
CATEGORIES= games
MASTER_SITES= http://gottcode.org/gottet/
@@ -16,15 +16,21 @@ LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= compiler:c++11-lib qmake tar:bzip2
-USE_QT5= buildtools_build widgets
-INSTALLS_ICONS= yes
+USE_GL= gl
+USE_QT5= core gui widgets \
+ buildtools_build linguisttools_build
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
post-patch:
@${REINPLACE_CMD} -e \
's|share/man|man|' ${WRKSRC}/gottet.pro
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e \
+ '/INSTALLS/s|qm||' ${WRKSRC}/gottet.pro
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} CREDITS ChangeLog NEWS README \