aboutsummaryrefslogtreecommitdiffstats
path: root/games/ksquares/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ksquares/Makefile')
-rw-r--r--games/ksquares/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/games/ksquares/Makefile b/games/ksquares/Makefile
new file mode 100644
index 000000000000..9b40bffda785
--- /dev/null
+++ b/games/ksquares/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= ksquares
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= games kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+USES= cmake:outsource gettext kde:5 tar:xz
+USE_KDE= auth codecs completion config configwidgets coreaddons crash \
+ dbusaddons ecm guiaddons i18n iconthemes itemviews kio \
+ libkdegames notifyconfig widgetsaddons xmlgui
+USE_QT5= core dbus gui network qml quick widgets xml \
+ buildtools_build qmake_build
+
+.include <${.CURDIR}/../kdegames/Makefile.common>
+.include <bsd.port.mk>