aboutsummaryrefslogtreecommitdiffstats
path: root/games/ksudoku/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ksudoku/Makefile')
-rw-r--r--games/ksudoku/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/ksudoku/Makefile b/games/ksudoku/Makefile
new file mode 100644
index 000000000000..832e79d834d1
--- /dev/null
+++ b/games/ksudoku/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: ksudoku
+# Date created: 30 September 2005
+# Whom: Bartosz Fabianowski <freebsd@chillt.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ksudoku
+PORTVERSION= 0.3
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= freebsd@chillt.de
+COMMENT= A Sudoku generator and solver for KDE
+
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
+USE_LIBTOOL_VER=15
+USE_KDELIBS_VER=3
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build on FreeBSD 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>