aboutsummaryrefslogtreecommitdiffstats
path: root/games/lbreakout/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/lbreakout/Makefile')
-rw-r--r--games/lbreakout/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index 837af8dfe7be..d503b3a78bb9 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -8,14 +8,13 @@ CATEGORIES= games
MASTER_SITES= SF/lgames/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A nice clone of classical Breakout game
+COMMENT= Nice clone of classical Breakout game
USE_SDL= sdl
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-lcompat"
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
@@ -23,12 +22,6 @@ post-patch:
s|<SDL/SDL|<SDL|g'
pre-install:
- ${MKDIR} /var/games/${PORTNAME}
-
-post-install:
- ${CHOWN} root:games ${PREFIX}/bin/${PORTNAME}
- ${CHMOD} 2755 ${PREFIX}/bin/${PORTNAME}
- ${CHMOD} 664 /var/games/${PORTNAME}/${PORTNAME}.hscr
- ${CHOWN} root:games /var/games/${PORTNAME}/${PORTNAME}.hscr
+ ${MKDIR} ${STAGEDIR}/var/games/${PORTNAME}
.include <bsd.port.mk>