aboutsummaryrefslogtreecommitdiffstats
path: root/games/lincity-ng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/lincity-ng/Makefile')
-rw-r--r--games/lincity-ng/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
index c2fb9afe4323..2633294c0922 100644
--- a/games/lincity-ng/Makefile
+++ b/games/lincity-ng/Makefile
@@ -24,7 +24,8 @@ USE_SDL= sdl mixer image ttf gfx
USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libphysfs=${PREFIX}
+CONFIGURE_ARGS= --with-libphysfs=${PREFIX} \
+ --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"