aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-candycruncher-demo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/linux-candycruncher-demo/Makefile')
-rw-r--r--games/linux-candycruncher-demo/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/games/linux-candycruncher-demo/Makefile b/games/linux-candycruncher-demo/Makefile
index 591d42b5c6fd..6593d9550964 100644
--- a/games/linux-candycruncher-demo/Makefile
+++ b/games/linux-candycruncher-demo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= candycruncher-demo
-PORTVERSION= 1.53
+PORTVERSION= 1.56
CATEGORIES= games linux
MASTER_SITES= http://demofiles.linuxgamepublishing.com/candycruncher/
PKGNAMEPREFIX= linux-
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .run
MAINTAINER= mva@FreeBSD.org
COMMENT= Candy Cruncher Demo - a fast puzzle game with lots of candies
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_LINUX= yes
USE_LINUX_APPS= alsalib jpeg libogg libvorbis mikmod sdl12 sdlmixer xorglibs
NO_CDROM= Redistribution is limited, see license
@@ -25,6 +25,8 @@ NO_BUILD= yes
DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
SUB_FILES= candycruncher
PORTDOCS= README README.licenses README.unixthanks license.txt
+LIBFILES= libcrypto.so.0.9.8 libgrapple-0.9.so.2 liblua.so liblualib.so \
+ libssl.so.0.9.8
.include <bsd.port.pre.mk>
@@ -35,14 +37,16 @@ do-extract:
do-build:
${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/Bin/candycruncher_demo
- ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/Bin/candycruncher_demo.dynamic
do-install:
@${MKDIR} ${DATADIR}/Bin
@cd ${WRKSRC}/bin/Linux/x86/Bin && \
- ${INSTALL_PROGRAM} candycruncher_demo candycruncher_demo.dynamic ${DATADIR}/Bin
+ ${INSTALL_PROGRAM} candycruncher_demo ${DATADIR}/Bin
@${INSTALL_PROGRAM} ${WRKDIR}/candycruncher ${PREFIX}/bin/${PKGNAMEPREFIX}candycruncher
@${CP} -R ${WRKSRC}/Resources ${DATADIR}
+ @${MKDIR} ${DATADIR}/lib/lib1
+ @cd ${WRKSRC}/lib/lib1/ && \
+ ${CP} ${LIBFILES} ${DATADIR}/lib/lib1
.if !defined (NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}