aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-quake3
diff options
context:
space:
mode:
Diffstat (limited to 'games/linux-quake3')
-rw-r--r--games/linux-quake3/Makefile8
-rw-r--r--games/linux-quake3/pkg-plist3
2 files changed, 6 insertions, 5 deletions
diff --git a/games/linux-quake3/Makefile b/games/linux-quake3/Makefile
index 781b49a5b18f..33a6c620ffef 100644
--- a/games/linux-quake3/Makefile
+++ b/games/linux-quake3/Makefile
@@ -18,14 +18,14 @@ MAINTAINER= pat@FreeBSD.org
COMMENT= Quake III Arena Dedicated Server for Linux
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
NO_WRKSUBDIR= yes
-Q3DIR= usr/games/quake3/
-PLIST_SUB+= Q3DIR="${Q3DIR}"
+Q3BASE= games
+Q3DIR= ${Q3BASE}/quake3/
+PLIST_SUB+= Q3DIR="${Q3DIR}" Q3BASE="${Q3BASE}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
do-extract:
diff --git a/games/linux-quake3/pkg-plist b/games/linux-quake3/pkg-plist
index 88a94199ab49..6f7c422a1252 100644
--- a/games/linux-quake3/pkg-plist
+++ b/games/linux-quake3/pkg-plist
@@ -95,4 +95,5 @@
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs/PunkBuster
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs/LinuxFAQ
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs
-@unexec rmdir %D/%%Q3DIR%% 2>/dev/null || echo "If you are permanently removing this port, you should do a ``rm -Rf ${PKG_PREFIX}/%%Q3DIR%%`` to remove any configuration files, *.pk3 files, and mods left." | fmt
+@unexec rmdir %D/%%Q3DIR%% >/dev/null 2>&1 || echo "If you are permanently removing this port, you should do a ``rm -Rf ${PKG_PREFIX}/%%Q3DIR%%; rmdir ${PKG_PREFIX}/%%Q3BASE%% >/dev/null 2>&1 || true`` to remove any configuration files, *.pk3 files, and mods left." | fmt
+@unexec rmdir %D/%%Q3BASE%% >/dev/null 2>&1 || true