aboutsummaryrefslogtreecommitdiffstats
path: root/games/linux-warsow/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/linux-warsow/Makefile')
-rw-r--r--games/linux-warsow/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/games/linux-warsow/Makefile b/games/linux-warsow/Makefile
index acf5bd7fc28f..f963d27f3ce7 100644
--- a/games/linux-warsow/Makefile
+++ b/games/linux-warsow/Makefile
@@ -1,7 +1,5 @@
# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
# $FreeBSD$
-#
PORTNAME= warsow
PORTVERSION= 0.12
@@ -44,15 +42,18 @@ DESKTOP_ENTRIES="Warsow" \
"Game;" \
false
-OPTIONS= CLIENT "Install client" on \
- SERVER "Install dedicated server" on \
- NVIDIA "Install support for nvidia" off
+OPTIONS_DEFINE= NVIDIA
+OPTIONS_MULTI= FLAVOR
+OPTIONS_MULTI_FLAVOR= CLIENT SERVER
+CLIENT_DESC= Install client
+SERVER_DESC= Dedicated server
+NVIDIA_DESC= Support for nvidia
+FLAVOR_DESC= Executable Selection
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= CLIENT SERVER
-.if defined(WITHOUT_CLIENT) && defined(WITHOUT_SERVER)
-IGNORE= requires at least one of CLIENT and SERVER options
-.endif
+.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if defined(WITH_NVIDIA)
. if !exists(${LINUXBASE}/usr/lib/libGL.so.1)