aboutsummaryrefslogtreecommitdiffstats
path: root/games/marsnomercy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/marsnomercy/Makefile')
-rw-r--r--games/marsnomercy/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/games/marsnomercy/Makefile b/games/marsnomercy/Makefile
index dcc4297510e3..3b7a874e11d7 100644
--- a/games/marsnomercy/Makefile
+++ b/games/marsnomercy/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= marsnomercy
-PORTVERSION= 0.1.2
-PORTREVISION= 1
+PORTVERSION= 0.2.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mars
@@ -29,7 +28,7 @@ SUB_FILES= mars-nomercy pkg-message
WRKSRC= ${WRKDIR}/mars-${PORTVERSION}
OPTIONS= DEBUG "With additional debug information" off \
- OPENGL "Install binary with opengl support" off
+ OPENGL "Install support for opengl" off
.include <bsd.port.pre.mk>
@@ -43,6 +42,12 @@ SCONS_ARGS+= debug=1
SCONS_ARGS+= debug=0
.endif
+.if defined(WITH_OPENGL)
+SCONS_ARGS+= with_opengl=1
+.else
+SCONS_ARGS+= with_opengl=0
+.endif
+
do-build:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} scons ${SCONS_ARGS}
@@ -58,11 +63,7 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
@${INSTALL_SCRIPT} ${WRKDIR}/mars-nomercy ${PREFIX}/bin
-.if defined(WITH_OPENGL)
- @${INSTALL_PROGRAM} ${WRKSRC}/mars_gl ${PREFIX}/libexec/mars
-.else
- @${INSTALL_PROGRAM} ${WRKSRC}/mars_sdl ${PREFIX}/libexec/mars
-.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/mars ${PREFIX}/libexec/mars
post-install:
@${CAT} ${PKGMESSAGE}