aboutsummaryrefslogtreecommitdiffstats
path: root/games/monster-masher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/monster-masher/Makefile')
-rw-r--r--games/monster-masher/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 0d8c9ce18e74..622bfed868b7 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: Monster-Masher
-# Date created: 26 Oct 2003
-# Whom: Koop Mast <einekoai@chello.nl>
-#
+# Created by: Koop Mast <einekoai@chello.nl>
# $FreeBSD$
-#
PORTNAME= monster
PORTVERSION= 1.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games gnome
MASTER_SITES= http://people.iola.dk/olau/monster-masher/source/
PKGNAMESUFFIX= -masher
@@ -16,17 +12,23 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Gnomemm puzzle game where you have to clean the caves of monsters
-LIB_DEPENDS= gnomecanvasmm-2.6.1:${PORTSDIR}/graphics/libgnomecanvasmm26 \
- gconfmm-2.6.1:${PORTSDIR}/devel/gconfmm26 \
- glademm-2.4.1:${PORTSDIR}/devel/libglademm24
+LIB_DEPENDS= gnomecanvasmm-2.6:${PORTSDIR}/graphics/libgnomecanvasmm26 \
+ gconfmm-2.6:${PORTSDIR}/devel/gconfmm26 \
+ glademm-2.4:${PORTSDIR}/devel/libglademm24
USE_BZIP2= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnome esound
+USES= pathfix
+USE_GNOME= gnomeprefix intlhack libgnome esound
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lesd
GCONF_SCHEMAS= monster-masher.schemas
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/pixbuf-drawing.hpp
+
.include <bsd.port.mk>