aboutsummaryrefslogtreecommitdiffstats
path: root/games/openssn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/openssn/Makefile')
-rw-r--r--games/openssn/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/games/openssn/Makefile b/games/openssn/Makefile
index d208f9300789..a2ee0eda1482 100644
--- a/games/openssn/Makefile
+++ b/games/openssn/Makefile
@@ -1,24 +1,25 @@
-# New ports collection makefile for: OpenSSN
-# Date created: 30, May 2011
-# Whom: Jesse Smith <jessefrgsmith@yahoo.ca>
-#
+# Created by: Jesse Smith <jessefrgsmith@yahoo.ca>
# $FreeBSD$
-#
PORTNAME= openssn
-PORTVERSION= 0.7
-PORTREVISION= 2
+PORTVERSION= 1.4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= jessefrgsmith@yahoo.ca
-COMMENT= A modern submarine simulator
+COMMENT= Modern submarine simulator
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE
+MAN6= openssn.6
+MANCOMPRESSED= yes
+
+USES= desktop-file-utils
USE_SDL= sdl gfx image mixer
USE_XORG= x11 xau xdmcp xext xmu xpm xxf86vm
WRKSRC= ${WRKDIR}/${PORTNAME}
+post-patch:
+ @${REINPLACE_CMD} -e 's,share/man/man6,man/man6,g' ${WRKSRC}/Makefile
+
.include <bsd.port.mk>