aboutsummaryrefslogtreecommitdiffstats
path: root/games/openttd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/openttd/Makefile')
-rw-r--r--games/openttd/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 786bb0bd025f..89d801c605f2 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openttd
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.3
CATEGORIES= games
MASTER_SITES= http://ftp.snt.utwente.nl/pub/games/openttd/binaries/releases/${PORTVERSION}/ \
http://us.binaries.openttd.org/binaries/releases/${PORTVERSION}/
@@ -21,7 +21,10 @@ USE_XZ= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= STRIP="${STRIP_CMD} ${STRIP}"
CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
-MAKE_ARGS= VERBOSE=1 # We want to see what's going on
+
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+MAKE_ARGS= VERBOSE=1
+.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CXXFLAGS= # Set to empty as OpenTTD treats it as an addition to CFLAGS