aboutsummaryrefslogtreecommitdiffstats
path: root/games/p5-Games-Bingo-Bot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/p5-Games-Bingo-Bot/Makefile')
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
index faaf738cfedf..c542cfbecee0 100644
--- a/games/p5-Games-Bingo-Bot/Makefile
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -16,17 +16,17 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Games::Bingo::Bot.3
+PORTEXAMPLES= bingobot.pl
+
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingobot.pl ${EXAMPLESDIR}
-.endif
-
-test:
- @cd ${WRKSRC}; make test
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingobot.pl ${STAGEDIR}${EXAMPLESDIR}
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} -s test
.include <bsd.port.mk>