aboutsummaryrefslogtreecommitdiffstats
path: root/games/plee-the-bear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/plee-the-bear/Makefile')
-rw-r--r--games/plee-the-bear/Makefile30
1 files changed, 28 insertions, 2 deletions
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
index cea924f1f4bb..78438b90814f 100644
--- a/games/plee-the-bear/Makefile
+++ b/games/plee-the-bear/Makefile
@@ -3,13 +3,20 @@
PORTNAME= plee-the-bear
PORTVERSION= 0.6.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Plee%20the%20Bear/${PORTVERSION:R}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 2D platform jump and run game
+LICENSE= GPLv2 CCbySA3
+LICENSE_COMB= dual
+LICENSE_NAME_CCbySA3=Attribution-ShareAlike 3.0 Unported
+LICENSE_FILE_CCbySA3=${WRKSRC}/CCPL
+LICENSE_PERMS_CCbySA3=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man
LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
claw_application:${PORTSDIR}/devel/libclaw
@@ -21,8 +28,27 @@ USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
USE_GCC= 4.6+
-USES= cmake gettext
+USES= cmake
CMAKE_ARGS= -Dlibclaw_DIR="${LOCALBASE}/share/libclaw/cmake" \
-DBEAR_NO_EDITOR=YES
+MAN6= plee-the-bear.6 running-bear.6
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/CMakeLists.txt
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|locale||' \
+ ${WRKSRC}/bear-engine/desktop/CMakeLists.txt \
+ ${WRKSRC}/plee-the-bear/desktop/CMakeLists.txt
+.endif
+
.include <bsd.port.mk>