aboutsummaryrefslogtreecommitdiffstats
path: root/games/plonx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/plonx/Makefile')
-rw-r--r--games/plonx/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/plonx/Makefile b/games/plonx/Makefile
index 0316e775f17f..1936703af6b0 100644
--- a/games/plonx/Makefile
+++ b/games/plonx/Makefile
@@ -14,16 +14,15 @@ PORTDOCS= README
LDFLAGS+= -lncurses
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
${WRKSRC}/${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>