aboutsummaryrefslogtreecommitdiffstats
path: root/games/qgo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/qgo/Makefile')
-rw-r--r--games/qgo/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 532f7af3de2b..760fca6c6a94 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -7,23 +7,23 @@
#
PORTNAME= qgo
-PORTVERSION= 0.0.11
+PORTVERSION= 0.0.14
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= kde@freebsd.org
+MAINTAINER= ports@freebsd.org
USE_REINPLACE= yes
-USE_QT_VER= 2
+USE_QT_VER= 3
GNU_CONFIGURE= yes
QTCPPFLAGS+= -DDONT_USE_GETOPT
CONFIGURE_ENV= QTDIR=${X11BASE}
USE_GMAKE= yes
post-patch:
- @${REINPLACE_CMD} -e "s,qt.so,qt2.so,g ; \
- s,/moc,/moc2,g" ${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s,-lqt,-lqt2,g" ${WRKSRC}/src/Makefile.in
+ ${REINPLACE_CMD} -e "s,libqt.so,libqt-mt.so,; \
+ s,-O2, ${CFLAGS} ${PTHREAD_CFLAGS}," ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s,-lqt,-lqt-mt ${PTHREAD_LIBS}," ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>