aboutsummaryrefslogtreecommitdiffstats
path: root/games/qix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/qix/Makefile')
-rw-r--r--games/qix/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/games/qix/Makefile b/games/qix/Makefile
index 4436602c1051..19139c016948 100644
--- a/games/qix/Makefile
+++ b/games/qix/Makefile
@@ -14,18 +14,15 @@ MASTER_SITE_SUBDIR= jmz
MAINTAINER= jmz@FreeBSD.org
COMMENT= The classic arcade game
+BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
+RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
+
.if defined(WITHOUT_X11)
MAKE_ARGS= NO_X11=yes
-.include <bsd.port.pre.mk>
.else
USE_X_PREFIX= yes
-.include <bsd.port.pre.mk>
PLIST= pkg-plist.x11
.endif
-.if ${XFREE86_VERSION} == 4
-BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
-.endif
.if !defined(DISPLAY) || ${DISPLAY} == ""
IGNORE= Requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X.
@@ -41,4 +38,4 @@ do-configure:
${SED} -e s:/usr/local:${PREFIX}: -e s:/usr/X11R6:${PREFIX}: \
< ${WRKSRC}/Makefile~ > ${WRKSRC}/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>