aboutsummaryrefslogtreecommitdiffstats
path: root/games/quake-reaper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/quake-reaper/Makefile')
-rw-r--r--games/quake-reaper/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/quake-reaper/Makefile b/games/quake-reaper/Makefile
new file mode 100644
index 000000000000..ceaaf2ef9d5d
--- /dev/null
+++ b/games/quake-reaper/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: quake-reaper
+# Date created: 15 Sep 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= reaper
+PORTVERSION= 0.81
+CATEGORIES= games
+MASTER_SITES= http://www.mindspring.com/~win32ch/
+DISTNAME= reaprb81
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Quake 1 bots
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in Autoexec.cfg PROGS.DAT
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}/${f:L}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in B08chg.txt Dedserv.txt Reaprb80.txt Skinspec.txt
+ @${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" ${WRKSRC}/${f}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/${f:L}
+. endfor
+.endif
+
+.include "${.CURDIR}/../quake-data/Makefile.include"
+
+.include <bsd.port.mk>