aboutsummaryrefslogtreecommitdiffstats
path: root/games/quake3
diff options
context:
space:
mode:
Diffstat (limited to 'games/quake3')
-rw-r--r--games/quake3/Makefile3
-rw-r--r--games/quake3/files/patch-code-unix-Makefile2
2 files changed, 2 insertions, 3 deletions
diff --git a/games/quake3/Makefile b/games/quake3/Makefile
index 39a40b3685bf..c2169387c04f 100644
--- a/games/quake3/Makefile
+++ b/games/quake3/Makefile
@@ -87,8 +87,7 @@ MAKE_ENV+= OPTIMIZED_CFLAGS=YES
.endif
.if ${PORT_OPTIONS:MTHREADS}
-MAKE_ENV+= SMP=YES \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV+= SMP=YES
PLIST_SUB+= SMP=""
Q3BIN+= quake3-smp
.else
diff --git a/games/quake3/files/patch-code-unix-Makefile b/games/quake3/files/patch-code-unix-Makefile
index d0417f503c58..21f7925e16bd 100644
--- a/games/quake3/files/patch-code-unix-Makefile
+++ b/games/quake3/files/patch-code-unix-Makefile
@@ -121,7 +121,7 @@
RANLIB=ranlib
-THREAD_LDFLAGS=-lpthread
-+THREAD_LDFLAGS=$(PTHREAD_LIBS)
++THREAD_LDFLAGS=-lpthread
# don't need -ldl (FreeBSD)
-LDFLAGS=-lm
+LDFLAGS+=-lm