aboutsummaryrefslogtreecommitdiffstats
path: root/games/scummvm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/scummvm/Makefile')
-rw-r--r--games/scummvm/Makefile17
1 files changed, 2 insertions, 15 deletions
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index ca58765d6b1e..4c1fde739a93 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scummvm
-DISTVERSION= 1.3.0
+DISTVERSION= 1.3.1
CATEGORIES= games emulators
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${DISTVERSION}
@@ -26,6 +26,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--disable-alsa \
--with-zlib-prefix=/usr \
--disable-debug \
+ --disable-nasm \
--disable-tremor
CONFIGURE_ENV= CXX="${CXX}"
LDFLAGS="${PTHREAD_LIBS}"
@@ -35,7 +36,6 @@ OPTIONS= VORBIS "Enable Ogg Vorbis support" on \
FLAC "Enable FLAC support" off \
FLUIDSYNTH "Enable FluidSynth MIDI synthesizer" off \
MT32EMU "Enable MT-32 emulator" on \
- X86_ASM "Enable assembly code (i386 only)" off
MAN6= scummvm.6
@@ -58,15 +58,6 @@ PLIST_DIRS= %%DATADIR%%
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-.if defined(WITH_X86_ASM)
-BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
-CONFIGURE_ARGS+=--with-nasm-prefix=${LOCALBASE}
-.else
-CONFIGURE_ARGS+=--disable-nasm
-.endif
-.endif
-
.if defined(WITH_VORBIS)
LIB_DEPENDS+= ogg.7:${PORTSDIR}/audio/libogg \
vorbis.4:${PORTSDIR}/audio/libvorbis
@@ -101,10 +92,6 @@ CONFIGURE_ARGS+=--disable-fluidsynth
CONFIGURE_ARGS+=--disable-mt32emu
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64: invokes i386 asm
-.endif
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/scummvm ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/dists/scummvm.6 ${PREFIX}/man/man6