aboutsummaryrefslogtreecommitdiffstats
path: root/games/sdlsand/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/sdlsand/Makefile')
-rw-r--r--games/sdlsand/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/sdlsand/Makefile b/games/sdlsand/Makefile
index 891e55f72d82..2e5293b73e84 100644
--- a/games/sdlsand/Makefile
+++ b/games/sdlsand/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= sdlsand
-PORTVERSION= 20060207
-PORTREVISION= 2
+PORTVERSION= 20061017
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= sldsand-src-${PORTVERSION}
MAINTAINER= amdmi3@mail.ru
COMMENT= Simulation of falling sand and other materials
@@ -20,14 +18,17 @@ USE_ZIP= yes
USE_SDL= sdl
USE_X_PREFIX= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/SDL\ Sand/SDL\ Sand
+WRKSRC= ${WRKDIR}/SDL\ Sand/SDL\ Sand
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= readme.txt
+post-patch:
+ @${REINPLACE_CMD} -e '/crtdbg/ d' ${WRKSRC}/CmdLine.cpp
+
do-build:
cd ${WRKSRC} && ${CXX} -o ${PORTNAME} ${CXXFLAGS} \
- `${SDL_CONFIG} --cflags --libs` main.cpp
+ `${SDL_CONFIG} --cflags --libs` main.cpp CmdLine.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin