aboutsummaryrefslogtreecommitdiffstats
path: root/games/sl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/sl/Makefile')
-rw-r--r--games/sl/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/sl/Makefile b/games/sl/Makefile
index 8c282bb147e9..90537cf70c3d 100644
--- a/games/sl/Makefile
+++ b/games/sl/Makefile
@@ -8,14 +8,18 @@ CATEGORIES= games
MAINTAINER= hym@cocoa.freemail.ne.jp
COMMENT= Steam locomotive runs across the screen if you type "sl" instead of "ls"
+USES= ncurses
USE_GITHUB= yes
GH_ACCOUNT= mtoyoda
-PLIST_FILES=bin/${PORTNAME} man/man1/${PORTNAME}.1.gz man/ja/man1/${PORTNAME}.1.gz
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ man/ja/man1/${PORTNAME}.1.gz
PORTDOCS= *
do-build:
- ${CC} ${CFLAGS} -I${WRKSRC} -o ${WRKSRC}/sl ${WRKSRC}/sl.c -lncurses
+ ${CC} ${CFLAGS} -I${WRKSRC} -o ${WRKSRC}/sl ${WRKSRC}/sl.c \
+ ${LDFLAGS} -lncurses
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin