aboutsummaryrefslogtreecommitdiffstats
path: root/games/spellcast/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/spellcast/Makefile')
-rw-r--r--games/spellcast/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/games/spellcast/Makefile b/games/spellcast/Makefile
index 47f8db521cdd..f850d0367545 100644
--- a/games/spellcast/Makefile
+++ b/games/spellcast/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: spellcast
-# Date created: 28 June 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= spellcast
PORTVERSION= 1.2
@@ -18,15 +14,21 @@ COMMENT= Multiplayer fight with spells turn based game for X Window System
USE_XORG= x11
MAN6= spellcast.6
+PLIST_FILES= bin/spellcast
+PORTDOCS= README spelllist.ps
+
+CFLAGS+= -Wno-return-type
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spellcast ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/spellcast.6 ${PREFIX}/man/man6
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/spellcast
-.for file in README spelllist.ps
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/spellcast
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>