aboutsummaryrefslogtreecommitdiffstats
path: root/games/vamos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/vamos/Makefile')
-rw-r--r--games/vamos/Makefile51
1 files changed, 38 insertions, 13 deletions
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index 736c6d1ef196..28dcada294f0 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -1,21 +1,19 @@
-# Ports collection makefile for: vamos
-# Date created: Mar 15, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= vamos
PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= SF \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An automotive simulation framework
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Automotive simulation framework
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
@@ -23,18 +21,32 @@ USE_OPENAL= al alut
USE_XORG= sm ice x11 xi xext xmu
USE_GL= glut
USE_SDL= sdl
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= ac_cv_header_boost_test_unit_test_hpp=no \
ac_cv_lib_freeglut_glutGetModifiers=no
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-INFO= vamos
-
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+# Wrong versioning upstream
+PORTSCOUT= skipv:0.7.1
+
+INFO= vamos
+
+PORTDOCS= AUTHORS ChangeLog README TODO
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+
+DESKTOP_ENTRIES="Vamos" "${COMMENT}" ${PORTNAME} \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-extract:
@${CHMOD} ${BINMODE} ${WRKSRC}/config/install-sh
@@ -46,4 +58,17 @@ post-patch:
/^AM_CXXFLAGS/s| -DBOOST_TEST_DYN_LINK|| ; \
/^AM_CXXFLAGS/s| -L/usr/lib/boost||'
+post-install:
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>